Happy New Year 2018! Mac SSD Upgrade failure. Good Tech Support and it’s cold!

2018: A New Year

So yeah, it’s a new year! Another one! So Happy New Year and I hope that 2018 brings you everything you want it to! I spend it quietly at home, sleeping by the time midnight rolled around. It’s really just another day for me, not really having any magical meaning other than having to remember to use the new year for dates. I’d say for writing checks, but I only write one or two a year now – the bank writes most of them for me and has done for many years now.

I think the biggest thing I like about the new year, is I can work on my taxes. I have so many expenses for the farm house this year that I needed to prepare as much as I could. I’ve organized things so far, and now I’m just awaiting various documentation to arrive. Will see what Turbo Tax Home & Business will do for me before heading out to see a real professional. If Turbo indicates a possible audit, then I’ll definitely see professional help and get someone to help me with my taxes too.

Replacement 1TB SSD drive for Mac Pro a No Go!

This week, I decided to buy a new SSD to replace my upgrade that I did about a year ago (see image on the left on the old upgrade). I went from a 256 GB drive to a 1 TB drive. Of course this is for my Mac Pro  (Late 2013, looks like a can) system. Apples new Mac OS High Sierra isn’t compatible with my upgraded SSD so after some research I decided to just get one that is compatible. Going to a good place, MacSales (OWC) and place my order for an “open box” unit that still was close to $600. It arrived yesterday so i decided today would be a good day to install it. I was not wrong, but it’s not as easy as the little over 2 minute video indicated.

Apparently, the drive I received was dead on arrival. Not sure if you could call it a drive, because it looks like flat stick with a couple of chips on it. I didn’t know that at first, but after installing it and trying to boot, it wouldn’t recognize it in order to restore to it. But that wasn’t the first thing I had to do, nope. I had to put in the original drive, and update to the latest version of the Mac OS. I had saved that so it wasn’t a big deal. I removed the old upgrade, a square fat thing that isn’t sexy at all, but it was 1TB in disk space and was hidden, so a year ago when I bought it (~$900), it was an investment worth the price, little did I know (and the manufacturers) would know that it couldn’t be used by the new Mac OS.

So, I put the old, original 256GB SDD in, and updated the OS. It took about an hour or so. Once it was up and running, I attempted the swap I mentioned above. to use the new SSD. But, as stated, my system couldn’t see it. I said, well, shit, that sucks (or words similar to that). Anyway, I decided to pull the new drive out and insert the older 1TB upgrade SSD back in. I could now install the MacOS on it, because apparently the biggest issue was the EFI (some firmware) that is installed. That’s put into the hardware so I could then safely (?) install the MacOS onto the Older, 1TB SSD. It worked, things seem to be going well with it, however, about 2 hours of running it, the system stopped responding.

I did everything I could think of and couldn’t get it to respond enough (the caps lock light would toggle, but no screen image, not other beeps or responses). I did what a normal tech support would do and powered it off. After a few moments I hit the power again and it started coming up, slowly. But when the screen appeared, it was the restore screen and not the normal login I’m used to. So OK. I take a look.

In the disk utility I found the disk but it was not showing as it’s full size, but a 240 GB drive instead, and was not initialized. Bummer. No problem, I put the original 256GB SSD in the slot, and started installing all over again. But my Time Machine backups had too much data to fit the smaller drive. I had a 1TB drive after all, but only about ~460 GB used, but it’s still too much for the smaller hard drive. I’m now doing a “migration” type restore after clean install of the OS and then I had to tell it to skip some folders. Not a huge deal since I know I have copies of everything – perhaps now is a good time to clean up and get rid of those applications I no longer use or need.

Of course at some point in doing this I submitted a support request to OWC and I’m awaiting their response. The best would be for them to send me another drive (at the same price, since this was appears to be dead) or just allow me to return it for a refund. I was hoping to send the old upgrade 1TB back to them for a $300 rebate which would bring the whole costs down a bit. Not sure if that is going to happen if I don’t get a new swapped drive. We’ll have to wait and see the results of that. At least I have my Mac Pro up and running again and have plenty of external storage, albeit slower, to keep my digital things.

Das Keyboard – Great Customer Support from this Austin, TX Company

One of my favorite purchases this past year was from January. This is a “clicking” keyboard with a USB 3.0 hub and I’ve used it a lot while working at home. It’s an awesome keyboard that costs me about ~$160.00 when I bought it. The only problem is that it came with a 2 meter (about 6 feet) long USB cord to plug it into the computer. Not only did that cord connect the keyboard and the USB 3.0 2 port Hub, but apparently it was a very tasty thing for Lacie, my youngest cat. She’s chewed the cable and now if it is turned in certain ways, it cause a short, which cause the laptop to disable to USB port it’s plugged into.

I did some searching online and I wasn’t able to find a replacement cord. So I asked myself, what if we submitted a request to their tech support asking for some advice. I was honest and told them what happened. I sent along with the request a copy of my Amazon order (invoice), the sticker showing the information from the bottom of the unit and the damaged cord. My main question was how we could proceed in getting a new usb cord (hard wired in the keyboard). I asked if it was something I could do or if I could send it in for repair.

Within less than an hour of submitting my “ticket”, Jared M. responded with a similar story about his beagle. He said he could feel my pain. If I would provide a shipping address, he would find a cable and send it my way. At no point did he mention charging me for the cord or for shipping it to me. Another hour or so of getting my address to him (via the online support system), he’s told me he’s prepared it for shipping and I should be getting it within 5 to 10 days. That was awesome and those are the kinds of stories one want to have when working with customer or technical support teams.

Friggin’ Cold

So, it’s been cold this week. Including in SC where they got some snow. The farm house air handler’s motor burned up and stopped warming the house. Fortunately, it’s under warranty so it only cost the labor and a new breaker. Thankfully it wasn’t all that, I need a break for a while on Farm house expenses! Here in Maryland, it’s been in the teens and below freezing for over a week. There is ice and snow on the ground, but it’s not too bad.

Leave a Reply